Davide posted a (micro-)blog entry noting to use the word "widget" rather than "applet" which caused a small flurry of conversation in the comments around the possible reasons for this. In Plasma we rarely do things without thought and conversation and so, yes, there are good reasons for this.
First off, Applet is not a well known word in the user populace. I've actually done semi-formal surveys of people to figure out which words are recognized by them and which aren't, and despite "Java applet" being a part of our technology vocabulary for quite a while, the average person doesn't really connect the word "applet" with anything overly meaningful. Many KDE users know "applet" from kicker, but that's not a huge percentage of the world population. "Plugin", thanks to web browsers, is probably the winning word but because it's associated with web browsers so strongly and has a well understood it wasn't really an option.
Widget, however, is increasingly used by people to mean "those little mini-apps that you put on your desktop, in our browser, on your phone etc". Therefore we have MacOS Dashboard Widgets, Vista Widget, Yahoo Widgets, Opera Widgets ... Google Gadgets are one of the odd ducks there. The others are of the form "$TYPE Widget".
Of course, we also have the word "Plasmoid". A Plasmoid is a native Plasma widget, meaning that it uses the Plasma facilities for theming, widgets, data, services, etc. Since Plasma is a canvas that you can put more than just Plasmoids on, though, we decided to use the generic term "widget" everywhere.
The point is that the user should not need to care what language or what widget toolkit something is written with. They are all "widgets" and why they don't work well together is a technical issue not a user issue. Exposing that to the user, therefore, is not the way to go. They are all widgets. They all work on Plasma. The user need not understand the fine points if they don't want to (though they can drill down if they wish).
For those who were concerned that we already have a meaning for the name "widget" in the sense of pushbuttons, menus, etc. that's confusing technical jargon with user facing language. As a developer, I don't get confused when there is a Plasma::PushButton which is a "widget" but all the Plasmoids are also "widgets". I know the distinction, and it's pretty easy to sort out. The typical user doesn't know the word for "all things pushy and poppy and clicky" and so doesn't face this confusion at all in the first place.
So, in summary, we picked a word that is already being used as a generic term for these things by many others, which would minimize confusion and which was accurate given the broad nature of Plasma.
Now we just need to remember to always use the word consistently in our communication. :)